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Prerequisiti 
Conoscenza delle funzionalità di base di ArcView (Unità n° 0), utilizzo delle query 
alfanumeriche (Unità n° 8) e nozioni di base sui GIS, in particolare sui criteri di selezione 
spaziale. 
 
 
Obiettivi formativi 
Mentre l'unità 8 affronta il tema della selezione degli oggetti geometrici tramite query 
alfanumeriche, lo svolgimento di questa unità ha lo scopo di introdurre i concetti di selezione 
sulla base di semplici relazioni topologiche esistenti tra gli oggetti geometrici. 
 
 
Parole chiave 
Topologia, buffer, overlay. 
 
 
Durata esercitazione 
90 minuti 
 
 
Materiale utilizzato 
3 archivi in formato shape (lim_amm.shp, ferrovie.shp e strade.shp) contenenti 
rispettivamente i poligoni relativi alla delimitazione amministrativa dei comuni del Triveneto, le 
linee ferroviarie e le linee della viabilità principale. I dati sono registrati in coordinate Gauss-
Boaga fuso ovest. 
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Introduzione 
Sebbene la tecnologia GIS sia nata negli anni attorno 1970, ancora oggi molti fra i suoi 
utilizzatori non sono sempre consapevoli dell'estrema sua grande flessibilità e delle sue 
potenzialità, e si limitano a sfruttarne le funzionalità di produzione cartografica e di creazione 
di report cartacei. In effetti i GIS possono fare molto di più: consentono di effettuare analisi, 
ovvero di investigare in profondità i dati per conoscere le relazioni esistenti tra gli oggetti 
spaziali e, in definitiva, per creare nuove informazioni che diano la possibilità di meglio 
interpretare la realtà e di intervenire su di essa con scelte appropriate. 
A volte, anche la conoscenza delle potenzialità dei GIS in materia di analisi dei dati non è 
sufficiente per produrre "buone" analisi e, in definitiva, "buone" mappe, ovvero mappe che 
siano in grado di presentare in modo chiaro e con accuratezza le informazioni frutto delle 
elaborazioni effettuate. Effettuare un'analisi significa innanzitutto porsi delle domande sulle 
informazioni di cui si ha bisogno. Tanto più specifiche e dettagliate sono le domande tanto più 
semplice sarà la scelta dei metodi prescelti per analizzare i dati e la possibilità di ottenere una 
buona rappresentazione dei risultati. 
Il processo di analisi può sostanzialmente essere interpretato come una sequenza 
di alcune operazioni che potremmo così sintetizzare: 
�� conoscenza delle caratteristiche dei dati; 
�� scelta del(i) metodo di analisi; 
�� elaborazione dei dati; 
�� controllo dei risultati. 
Naturalmente il processo può essere soggetto a verifiche e revisioni in qualsiasi momento, in 
relazione agli obbiettivi iniziali ed in rapporto ai risultati ottenuti. Un controllo più accurato dei 
dati iniziali ed una loro eventuale intergrazione, la scelta di metodologie di analisi ed 
elaborazione diverse rispetto a quelle inizialmente adottate, possono condurre a risultati più 
rispondenti agli obbiettivi originari. 
La principale peculiarità dei software GIS rispetto ai CAD risiede nella capacità di elaborare e 
trasformare i dati spaziali per rispondere a specifiche necessità di analisi ed interrogazione. 
Sebbene alcune funzionalità siano comuni agli ambienti CAD e GIS, solo con questi ultimi si 
possono effettuare analisi topologiche o spaziali dei dati geografici, combinandole 
eventualmente ad analisi effettuate sugli attributi non spaziali (alfanumerici) dei dati. Lo 
sviluppo di software GIS che utilizzano interfacce grafiche sempre più "amichevoli" ha 
semplificato di molto le operazioni di analisi geo-spaziale, anche quelle più complesse. 
Le operazioni di selezione ed analisi spaziale spesso coinvolgono più livelli informativi 
geografici (temi). In particolare ricadono sotto il nome di "overlay" tutte quelle elaborazioni 
che, utilizzando più temi contemporaneamente e sulla base delle relazioni spaziali esistenti tra 
gli oggetti ad essi appartenenti, consentono di selezionare gli elementi di uno o più layer 
oppure di ottenere come risultato la creazione di un nuovo tema. Durante questa unità 
verranno prese in considerazioni solo le procedure utilizzate per la selezione. 
Si parla di selezione spaziale quando l’operazione consente di individuare gli oggetti presenti in 
uno o più livelli geografici in relazione ai criteri di ricerca geometrico-topologica adottati. Negli 
esempi esposti in seguito saranno prese in considerazione solo alcune delle possibili interazioni 
spaziali tra gli oggetti geometrici, mentre le più comuni sono elencate sinteticamenete nel 
riquadro successivo. 
 



 

In ArcView i criteri di selezione spaziale si basano su sei specifici tipi di 

relazione che consentono di individuare gli oggetti dei temi attivi: 

(Are Completely Within) che sono interamenti contenuti all’interno degli 

elementi selezionati del tema di selezione; 

(Completely Contain) che contengono completamente gli elementi 

selezionati del tema di selezione; 

(Have their Center In) che hanno il centro che ricade all’interno degli 

elementi selezionati del tema di selezione; 

(Contain the Center Of) al cui interno ricade il centro degli elementi 

selezionati del tema di selezione; 

(Intersect) che hanno almeno un punto in comune con gli elementi 

selezionati del tema di selezione (compresi anche tutti gli oggetti interamente 

contenuti); 

(Are Within Distance Of) che si trovano ad una distanza specificata dagli 

elementi selezionati del tema di selezione. 



 
Selezione per tema in ArcView 
In questa sezione viene presentato il procedimento da utilizzare in ArcView per selezionare gli 
oggetti appartenenti ad un tema, specificando quale relazione spaziale  deve essere verificata 
rispetto agli oggetti appartenenti ad un altro tema. 
In particolare affronteremo un problema che potremmo definire di "accessibilità", consistente 
nell'individuare i comuni delle province di Padova e Treviso che sono attraversati da linee 
ferroviarie e i cui confini non distano piu' di 2 km dalla rete autostradale. Il problema specifico 
richiede due successive operazioni di selezione, ovvero di individuazione dei comuni per i quali 
sono rispettate entrambe le condizioni proposte. 
 
1. Aprire ArcView e iniziare un nuovo progetto. E' possibile salvare il progetto in qualsiasi 
momento (File -> Save Project, oppure File -> Save Project As…). La prima volta che si 
salva un nuovo progetto, ArcView apre la finestra di dialogo Save Project As da utilizzare per 
indicare il nome del progetto e la directory nella quale deve essere salvato: in questo caso 
digitare unita10.apr nel campo di testo File Name. 

2. Aggiungere al progetto un documento di tipo vista (doppio clic sull'icona  nella finestra 
di progetto). 
2.1. Indicare le unità di misura delle coordinate della mappa presente nella vista aprendo la 
finestra di dialogo View Properties (View -> Properties…): impostare le voci Map Units e 
Distance Units assegnando loro il valore meters. Fare clic sul bottone OK per chiudere la 
finestra di dialogo. 
2.2. Aggiungere alla vista il tema lim_amm.shp (View -> AddTheme…). Aggiungere anche i 
temi ferrovie.shp e strade.shp. 
 
3. A questo punto iniziano le operazioni specifiche riguardanti l'esempio proposto. Siccome i 
criteri di selezione sono due, sarà necessario ripetere per due volte la procedura di seguito 
indicata, naturalmente impostando i parametri in modo appropriato in funzione del criterio di 
selezione adottato. Dato che l'esempio prende in considerazione i soli comuni (200) 
appartenenti alle province di Padova e Treviso, è necessario selezionare preventivamente tali 
comuni (per fare ciò è sufficiente utilizzare una query che agisca sul campo provincia della 
tabella degli attributi del tema Limiti amministrativi (l'utilizzo delle query per la selezione di 
oggetti geometrici è stato trattato nel corso dell'unità 8). Dopo aver selezionato i comuni 
interessati dall'indagine, si può iniziare la ricerca di quelli attraversati dalle linee ferroviarie. 
3.1. Aprire la vista e nella rendere attivo il tema Limiti amministrativi. 
3.2. Aprire il menu Theme e selezionare la voce Select By Theme…; si apre la finestra di 
dialogo Select By Theme che consente di impostare i parametri richiesti dai criteri di 
selezione dei comuni. Come si può notare, nella finestra di dialogo vengono visualizzati due 
elenchi a discesa: quello in alto riporta le possibili relazioni spaziali tra i temi attivi (nel nostro 
caso il tema attivo è solo quello con i Comuni), quello in basso la lista dei temi fra i quali 
scegliere quello da utilizzare per la selezione. 
3.3. Innanzitutto si deve indicare quale relazione spaziale deve intercorrere tra gli oggetti del 
tema "Limiti amministrativi" e gli oggetti selezionati del tema Ferrovie (in questo caso non 
avendo selezionato alcun oggetto dal tema Ferrovie l'operazione di selezione utilizzerà tutti gli 
oggetti del tema): il criterio da scegliere è Intersect, indicando con ciò che si vogliono 
individuare gli elementi del tema Limiti amministrativi che intersecano geometricamente gli 
elementi del tema Ferrovie. Quest'ultimo deve essere scelto tra quelli presenti nell'elenco a 
discesa posto in basso. Dopo aver impostato i parametri fare clic sul pulsante Select from 
set, in modo da individuare i comuni solamente tra quelli già selezionati appartenenti alle 
province di Padova e Treviso. Dato che la relazione geometrica di intersezione è simmetrica, 
il risultato della selezione può essere interpretato come l'individuazione degli elementi del tema 
Limiti amministrativi che sono intersecati dagli elementi del tema Ferrovie. Al termine di 
questa prima fase della selezione per tema, risultano selezionati 77 comuni. 
3.4. La seconda fase della selezione prevede di "raffinare" ulteriormente la selezione dei 
comuni ricercando, tra quelli attualmente selezionati, solo quelli i cui confini non distano più di 
2 km dalla rete autostradale. I temi coinvolti nella selezione sono Strade e, naturalmente, 
Limiti amministrativi. Dal tema strade è necessario selezionare solo le autostrade 
(impostare una query sul campo infrastrut). A questo punto si procede come già visto ai punti 



3.2 e 3.3, ricordando però che in questo caso la relazione spaziale da scegliere è Are Within 
Distance Of ed il tema da utilizzare per la selezione è Strade. L'indicazione della relazione 
Are Within Distance Of implica la necessità di specificare la distanza massima che deve 
intercorrere tra gli oggetti appartenenti ai due temi: nella casella di testo che compare nella 
parte inferiore della finestra di dialogo deve essere inserito il valore 2000 (si ricordi che l'unità 
di misura della mappa è il metro). Facendo nuovamente clic sul pulsante Select from set la 
selezione viene completata e sulla vista vengono evidenziati i comuni che rispettano i nostri 
criteri di selezione spaziale (in totale 36). 
 
 
Approfondimenti: creazione di buffer attorno a oggetti geometrici 
Quali sono le aree che si trovano ad una determinata distanza da un impianto industriale a 
rischio? Quanta popolazione e in che misura è interessata da un eventuale straripamento di un 
fiume? In quale zona della città è più opportuno localizzare una nuova attività commerciale? 
Questi sono solo alcuni esempi di possibili domande che hanno come denominatore comune la 
necessità di conoscere informazioni relative all’intorno di specifiche localizzazioni che 
individuano particolari oggetti o eventi. La determinazione geometrica di questo intorno e delle 
distanze (metriche, temporali o, più in generale, espresse in termini di costi) esistenti tra gli 
oggetti considerati è uno dei problemi di analisi GIS di più frequente utilizzo. 
Il metodo più semplice e rapido per determinare "cosa si trova vicino a" è quello che fa ricorso 
alla distanza in linea retta. Utilizzando tale metodo è possibile specificare gli elementi e la 
distanza di riferimento per individuare l’area interessata dall’analisi. Questo procedimento 
consente di effettuare non solo operazioni di selezione come quelle presentate nell’esempio del 
paragrafo precedente, ma anche altri tipi di analisi tra cui quella che prende il nome di 
"creazione di buffer". Dal punto di vista geometrico, il buffer è un poligono il cui perimetro 
individua una zona di territorio che si trova ad una distanza -rispetto agli oggetti di interesse- 
compresa tra i valori minimi e massimi indicati. Ad esempio, se si richiede il buffer relativo ad 
una distanza d rispetto ad un punto, il poligono creato sarà un cerchio avente un raggio di 
lunghezza d. Rispetto ad un elemento lineare, il buffer corrisponde ad un poligono il cui 
perimetro si trova alla distanza specificata dalla linea. Nel caso di un elemento poligonale, il 
buffer individua un poligono il cui perimetro esterno si trova alla distanza indicata dal 
perimetro del poligono di base. E’ inoltre possibile richiedere la creazione di buffer utilizzando, 
come distanze, i valori variabili letti da un campo di una tabella di attributi. Ad esempio, si 
potrebbero creare buffer di dimensioni diverse per individuare le fasce di rispetto relative a 
diverse tipologie di strade (es. 60 m per le autostrade, 40 per le strade statali e a grande 
percorrenza, ecc.). 
In ArcView è possibile creare buffer utilizzando l’apposita procedura guidata accessibile tramite 
la voce di menu Theme -> Create Buffer…. Prima di attivare la procedura è necessario 
impostare le unità di mappa e di distanza della vista utilizzando la finestra di dialogo View 
Properties (View -> Properties…). 
 
 
Risorse in rete 
In generale, si rimanda alle risorse indicate nelle altre unità, e si segnalano inoltre: 
 
http://www.cyber.vt.edu/LSG/intro/gis/arc1.htm 
un tutorial ArcView con esempi di utilizzo delle selezioni spaziali (Step 10). 
 
http://www.uottawa.ca/academic/arts/geographie/lpcweb/web2320/ArcVw/spatial_analysis.htm 
con interessanti esempi di selezione per tema in ArcView. 
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