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Introduzione 
L’utilizzo dei dati geografici in formato digitale è sempre un percorso complesso per le implicite 
conoscenze multidisciplinari. Conoscere la struttura dati geografica, i contenuti informativi, i 
dati tabellari descrittivi che possono interagire con i dati geometrici è indispensabile in quanto 
motore delle query per una efficace interrogazione spaziale o tabellare. I dati geografici digitali 
sono di natura dinamica, scoprire e familiarizzare è necessario per acquisire le tecniche 
nell’impostare le relazioni fra dati spaziali e dati tabellari attraverso la potenzialità del software 
ArcView, con le sue interfaccie e l’utilizzo dei suoi comandi. In particolare è sempre utile 
ancora prima di iniziare qualsiasi lavoro di elaborazione approfondire con appropriati strumenti 
di analisi e di conoscenza i contenuti e la struttura dati di input. Informazioni che si rivelano 
preziose per una buona impostazione del lavoro e soprattutto per un corretto uso dei dati.  

 
Prerequisiti  
Unità 0 e conoscenza dei principali comandi standard di Windows per la visualizzazione, 
l'organizzazione e la gestione dei file. 

 
Obiettivi Formativi  
In questa unità si introducono concetti legati alla importazione dei dati geografici proprietari 
(shape file) e, dei dati provenienti e prodotti da altri software attraverso i file di interscambio 
con il supporto delle interfacce grafiche di ArcView per la creazione di un progetto, che trova la 
sua origine nella gestione e nella elaborazione dei dati geografici. In questo corso si farà uso 
solo di dati shape come supporti di elaborazione e solo come esempio di importazione di dati 
provenienti da Autocad, con l’uso di file dwg o file di interscambio dxf.  
Prima di iniziare qualche informazione sull’argomento. ArcView è in grado di importare dati di 
diversa tipologia e con strutture diverse. Gli shape file sono dati grafici creati da ArcView, 
l’importazione, l’interrogazione, l’analisi e l’archiviazione di questi dati non crea alcuna 
difficoltà. Invece, l’importazione dei dati non proprietari, in particolare dati CAD (esempio 
costruiti o elaborati da Autocad) proprio per la loro struttura possono generare confusione se 
non si conosce il contenuto. Infatti ArcView nell’importare dati con struttura non proprietaria, 
comunque distingue e mantiene separati i dati di tipo linea, punto, poligono, testo. Con il 
proseguo dell’esercitazione si vedrà come ArcView risolve questi problemi attraverso semplici 
impostazioni che evitano o limitano le perdite di tempo.  
  



 

Parole chiave  
Shape file, file di interscambio, viste, progetti 
  
Durata  
90 minuti 
 
Materiale utilizzato  
Archivi in formato shape: 

• Infrastrutture.shp (contenente oggetti di tipo linea per la viabilità stradale e 
ferroviaria); 

• Idrografia.shp (contenente oggetti di tipo linea come fiumi, canali, ecc.); 
• Comuni_archi.shp (contenente oggetti di tipo linea per la delimitazione dell’area 

amministrativa per i singoli comuni delle provincie di Venezia, Padova, Treviso); 
• Comuni.shp (contenente i poligoni relativi all’area amministrativa dei singoli comuni 

delle provincie di Venezia, Padova, Treviso); 
• Centro_urbano.shp (contenente oggetti di tipo puntuale che rappresentano il centro 

urbano del singolo comune) 
 

Esercitazione 
 
1. Avvio di ArcView ed importazione dei dati 
Avvio di ArcView dal pulsante di Window: 
Avvio/Start -> Programmi -> Esri -> ArcView Gis 3.2 
All'avvio del programma la prima interfaccia si apre con tre finestre. La finestra in primo piano 
è quella attiva e riporta sulla barra del titolo Welcome to ArcView GIS, questa finestra 
presenta tre opzioni a scelta fra: whith a new View, as a blank project, Open an existing 
project. Click su as a blank project in quanto base di partenza per la creazione di un nuovo 
progetto. Per confermare la selezione click sul pulsante Ok. 
  
2. Le finestre ArcView - note introduttive 
La conferma chiude la finestra Welcome to ArcView GIS ed attiva le altre La più grande è la 
finestra generale, nella barra del titolo riporta ArcView GIS 3.2,  appena sotto la barra si 
trovano i menu a discesa File, Project, Windows, Help. Sotto il menu File e Project si 
evidenziano due pulsanti. Il pulsante  attiva il Save Project, il pulsante  è un Help.  
All’interno della finestra generale c’è la finestra di progetto. Su questa vengono scritti ed 
elencati dal sistema i componenti appartenenti ai vari documenti. Dalla finestra progetto è 
possibile rinominare, aggiungere, rimuovere i singoli componenti dal progetto stesso. Sulla 
barra del titolo il nome Untitled, sotto la barra i pulsanti New, Open, Print, di cui solo il 
pulsante New è attivo.  
Sotto il pulsante New ci sono cinque icone che rappresentano i documenti di Arcview: View, 
Tables, Charts, Layouts, Scripts. A destra una casella di riepilogo per il momento vuota. I 
documenti sono dei contenitori organizzati di ArcView. La caratteristica della finestra Untitled 
è quella di muoversi solo all'interno della finestra più grande in quanto dipendente.  
 
3. I documenti ArcView 

 View: è il modulo che consente l’importazione, l’interrogazione e l’analisi spaziale dei 
dati geografici e la modalità di visualizzazione. Il controllo e la gestione dinamica della legenda 
sui dati esistenti sono strumenti utili alla rappresentazione tematica; 

Tables: è il modulo che consente l’importazione, l’interrogazione, la visualizzazione e la 
gestione delle tabelle dei dati grafici e delle eventuali tabelle di dati alfanumeriche per dati 
collegati. In questo modulo si possono creare le relazioni fra le singole tabelle; 

Charts: è il modulo che consente la visualizzazione e la creazione di grafici partendo dai 
dati tabellari; 



 

Layouts: è il modulo che consente la preparazione e la composizione di mappe per 
l’output di stampa di ArcView e può contenere viste, diagrammi, tabelle, elementi grafici, testi, 
ecc. Un layout si può indirizzare direttamente verso una periferica di stampa per ottenere il 
supporto cartaceo, oppure è possibile esportare il contenuto del layout in un file con uno 
qualsiasi dei formati di output supportati da ArcView. I layout sono strutturalmente dinamici in 
quanto collegati ai dati rappresentati nelle singole viste, ogni modifica effettuata nella vista 
aggiorna in automatico anche il layout corrispondente. 

Scripts: è il modulo che consente ai programmatori di personalizzare gli ambienti di 
lavoro in ArcView attraverso il linguaggio Avenue. 
 
 
4. Creare una finestra grafica 
Per iniziare è necessario creare una finestra grafica per la lettura e il disegno dei dati grafici (le 
finestre di ArcView hanno le stesse proprietà di qualsiasi finestra di windows). Quindi, click sul 
pulsante New nella finestra Untitled. Questa azione aggiunge una nuova finestra dal titolo 
View1, contemporaneamente si modifica anche l'aspetto della finestra generale. Sono 
cambiati e si sono aggiunti dei menu a discesa, quali: File, Edit, View, Theme, Graphics, 
Windows, Help, ma, anche comandi a pulsante che saranno utilizzati nel proseguo 
dell'esercitazione o in altre unità.  
 
Nella creazione di una View il sistema in automatico assegna a questa il nome View1 dove il 
carattere finale “1” è una variabile progressiva ed assumerà “2”, “3”, ecc. a seconda di quante 
View si creano sequenzialmente. La finestra View definisce le modalità di visualizzazione dei 
dati geografici, di creare e gestire legende, di visualizzare la selezione sui dati tabellari ecc. La 
View ha una struttura dinamica, la modifica dei dati sorgenti comporta alla prima rigenerazione 
una modifica ed un aggiornamento della View che li contiene. 
 
5. Caratteristiche e proprietà della finestra grafica 
La finestra grafica View(n) è composta da due parti a dimensione variabile. Se spostiamo il 
cursore del mouse fino ad intercettare il limite di divisione delle due finestre che si trova 
appena a destra della barra di scorrimento verticale, notiamo che il cursore del mouse cambia 
aspetto e assume la forma di due freccette con orientamenti opposti, se premiamo e teniamo 
premuto il tasto sinistro del mouse muovendo il cursore verso destra o verso sinistra le finestre 
si modificano in sincronia. La parte più a sinistra della finestra si presenta con uno sfondo di 
default in grigio ed è riservato al sommario (toc, legenda), mentre la parte più a destra 
solitamente con uno sfondo bianco di dimensioni più grandi è riservata al disegno dei dati 
grafici o geografici. Ogni volta che si crea una nuova View questa è priva di qualsiasi 
riferimento metrico. La scala di visualizzazione dei dati è casuale, pur mantenendo una 
geometria corretta. I dati geografici privi di una unità di misura hanno una gestione difficile se 
non impossibile. Le proprietà metriche e descrittive della View si assegnano attraverso le View 
Properties.  
Per avviare, impostare, modificare i parametri selezionare il menu a discesa View -> 
Properties, un click di conferma attiva una finestra di dialogo per la gestione dei campi in 
essa contenuti. Ci sono campi in cui è possibile sostituire e digitare dei caratteri, oppure campi 
a selezione obbligata su un elenco a discesa, e ancora dei pulsanti. 
 

• Proprietà dei campi nella finestra View Properties:  
o Name: riporta il nome della vista di default View(n), si può rinominare. 

Selezionare il testo View1 e sostituire con Dati Geografici. E’ una buona regola 
associare un nome pertinente con il contenuto della vista. I progetti di solito 
contengono più viste, un nome appropriato è una introduzione al contenuto; 

o Creation Date: è la data del sistema; 
o Creator: se vogliamo ricordare chi ha lavorato in questa vista;  
o Map Units: è un campo a scelta obbligata fra quelle proposte su una lista a 

discesa. Si attiva con un click sul pulsante  e si seleziona l’unità di misura 



 

appropriata per poi confermare con un click del mouse. L’attivazione di questo 
campo con una scelta diversa da unknown attiva il campo sottostante. 
Scegliere una unità di misura comunque allineata con i dati di riferimento e di 
archiviazione determina una continuità metrica. I dati utilizzati in questa unità 
sono espressi in metri, quindi selezionare meters;  

o Distance Units: anche qui la scelta è obbligata fra quelle proposte. Non 
necessariamente deve essere uguale al campo Map Units ma per coerenza 
scegliere meters; 

o I pulsanti in fondo alla finestra Projection, Area of Interest, Select Color 
saranno oggetto di approfondimento in altre unità; 

o Comments: area testuale riservata alle note di supporto al lavoro.  
 
Modificare le proprietà nelle View Properties sono operazioni non obbligatorie ma consigliabili. 
In particolare è significativo attivare il campo Map Units con una scelta diversa da unknown 
fra le opzioni proposte per acquisire il controllo metrico dei dati contenuti nelle viste. La 
visualizzazione dei dati non è più lasciata al caso ma in ogni momento attraverso 

l’impostazione diretta della scala  o con l’utilizzo del comando zoom in o zoom 
out abbiamo sempre i dati in scala reale di rappresentazione. La scelta di una unità di misura 
attiva in sequenza il pulsante  Measure, utile strumento di misura. L’impostazione o la 
modifica anche parziale dei campi nella View Properties si può eseguire in qualsiasi 
momento, non ha alcuna conseguenza sui dati tabellari e nei contenuti geometrici.  
 
6. Importare i dati / Aggiungere i temi (shape file) 
Dal menu View -> Add Theme oppure click sul pulsante , questa sequenza di selezione 
apre una finestra di dialogo in cui è possibile muoversi nelle direttory fino a trovare i dati da 
caricare. (Ricordiamo che ArcView riconosce e distingue quattro tipi di dati grafici: linee, punti, 
poligoni, annotazioni). Inoltre nella casella di riepilogo Data Source Type è necessario 
verificare la selezione per Feature Data Source (e anche il default) e non Images Data 
Source in quanto quest'ultima indirizza il sistema a cercare delle immagini digitali escludendo 
dalla lista i dati shape. Si selezionano i file: Infrastrutture.shp, Idrografia.shp, 
Comuni_archi.shp, Comuni.shp, Centro_urbano.shp, singolarmente od a selezione multipla. 
Click sul pulsante OK per confermare. Si chiude la finestra di dialogo e si riattiva la finestra di 
visualizzazione Dati Geografici, apportando alla stessa delle modifiche nei suoi contenuti. Nella 
parte sinistra riservata al sommario si sono aggiunti e si leggono il nome del tema (o dei 
temi, dipende dalla selezione effettuata) con un simbolo (come già accennato ArcView 
identifica la caratteristica del dato e associa il tipo di simbolo) ed un colore del tutto casuale. 
Vicino al nome del tema nella parte sinistra un pulsante di attivazione.  

6.1 Regole di visualizzazione 
In ArcView si possono caricare i temi in un ordine qualsiasi, la visualizzazione dei dati 
invece ha qualche regola da rispettare. I dati in sommario scorrono dall’alto in basso, il 
primo tema “in alto” si considera sopra agli altri. Ad esempio se abbiamo dati di tipo 
poligono e dati di tipo linea e vogliamo rappresentare i poligoni come aree a campitura 
piena in un certo colore e, vogliamo anche mantenere la visibilità dei dati di tipo linea si 
intuisce subito che l’ordine dei temi in sommario non può essere casuale. Il tema 
poligonale deve stare sotto a quello lineare, invertire la posizione significa nascondere 
alcune informazioni. Lo scorrimento di posizione verso l’alto o verso il basso di un tema 
in sommario avviene attraverso un click con il pulsante sinistro del mouse sul tema 
stesso e mantenendo premuto il pulsante si scorre in alto o in basso fino alla posizione 
voluta. 
  
In sommario per avere una visione di tutti i dati caricati la sequenza dei temi partendo 
dal primo in alto: Centro_urbano.shp, Infrastrutture.shp, Idrografia.shp, 
Comuni_archi.shp, Comuni.shp. 
 
Se la finestra Dati Geografici non è stata ingrandita eseguire questa operazione per una 
visualizzazione dei dati d’insieme più adeguata. L’attivazione del tema e la 
contemporanea visualizzazione dei dati si esplica con un click del mouse sul  



 

pulsante di attivazione in sommario, appare il segno di spunta  come conferma 
dell’operazione. Nello stesso modo con un click sullo stesso pulsante si ottiene la 
disattivazione. 
 

7. Caratteristiche e proprietà dei temi 
Con l’impostazione delle proprietà in un tema si abilità un controllo su aspetti diversi. L’unità 
prenderà in considerazione solo alcune di queste. ArcView elabora, interroga e lavora sempre e 
solo sul tema attivo, click sul tema Comuni.shp per attivare. In sommario il tema attivo è 
riconoscibile perché in rilievo rispetto agli altri. Verificato quanto esposto, dal menu Theme -> 
Properties e conferma si apre una finestra di dialogo Theme Properties. Questa finestra ha 
caratteristiche e contenuti diversi secondo il bottone selezionato nell’area a scorrimento 
verticale.  
 

• Descrizione di alcune proprietà generali: 
o Il campo Theme Name è intuitivo nel contenuto e propone il nome del tema attivo, 

in questo caso Comuni.shp. La proprietà di questo campo consente di rinominare il 
tema a piacere, è sempre presente in qualsiasi bottone selezionato;  

   

o  attiva le proprietà: 
o Source, indica la path dove sono memorizzati i dati; 
o Definition, in questa casella di riepilogo vengono scritte dal sistema le 

interrogazioni di query eseguite attraverso l’attivazione e uso del pulsante 

 Query Builder; con questo pulsante si definiscono le query di 
interrogazione in base ai valori degli attributi per gli elementi grafici in una 
vista ed i relativi record in una tabella; 

o Clear, pulsante per la cancellazione delle query nella casella di dialogo; 
o Comments, area testuale riservata alle note. 
 

o  attiva le proprietà: 
o Minumun Scale, definisce la scala minima di visualizzazione di un tema 

digitando dei valori; 
o Maximun Scale, definisce il valore massimo di visualizzazione di un tema 

digitando dei valori. 
Per non equivocare:  
o quando si rinomina un tema non si rinomina il file di dati appartenente al tema 

ma solo il nome visualizzato in sommario;  
o nella definizione di scala minima e massima il tema ed i dati sono sempre 

presenti nel progetto ma sono visualizzati sulla finestra grafica solo se 
concordano nei parametri impostati.  

 
8. Importare dati diversi dagli shape 
Per importare dati non proprietari, elaborati da altri software, si devono attivare le estensioni 
dei moduli di importazione. E’ evidente che bisogna conoscere le estensioni dei file per 
individuare il software che le ha prodotte al fine dell’attivazione del modulo. 

• Le estensioni di ArView 
Le estensioni in ArcView sono utility che permettono l’importazione dei dati creati e 
generati da altri software. Questa possibilità evita la duplicazione di dati gia esistenti 
a condizione di conoscere contenuto e struttura al fine di valutare la convenienza. Le 
estensioni si possono attivare in qualsiasi momento, non interferiscono con il lavoro 
già avviato. Per attivare l’utility si seleziona il menu File -> Extensions al click del 
mouse si attiva la finestra Extensions con all’interno un elenco di specifiche che 
corrispondono ai vari formati di file che ArcView è in grado di importare. Click sul 
quadratino in rilievo per attivare l’utility, il segno di spunta conferma la scelta. Per 
noi e sufficiente al momento attivare Cad Reader (con questa attivazione ArcView 



 

riconosce i dati provenienti da Autocad sia nel formato dwg che dxf), click sul 
pulsante Ok. 
 
ArcWiev 3.2 importa correttamente i dati nei formati dxf e dwg di Autocad fino alla 
release 14 compresa. Non sempre le estensioni dei file riconducono al software che 
le ha generate per mancanza di informazioni e conoscenza, nel qualcaso una 
possibile soluzione è quella di attivare tutte le estensioni per obbligare ArcView  alla 
verifica ed al possibile riconoscimento  dei file.  
 
Attivata l’estensione si procede nel solito modo: dal menu View -> Add Theme  
oppure dal pulsante  si apre la finestra di dialogo per la ricerca dei file. 
Selezionare il file Comuni.dxf prima di confermare si clicca con il tasto destro del 
mouse sull’icona  questa operazione apre una sotto cartella di ulteriore selezione  

 
     

la scelta può essere singola o multipla (quest’ultima si effettua tenendo premuto il 
tasto Shift nella selezione). Selezionare polygon e point e click su OK. In 
sommario si sono aggiunti due temi con lo stesso nome comuni.dxf ma con una 
simbologia diversa per allinearsi alla selezione fatta. 
  

9. Il progetto ArcView 
Il progetto non è altro che un file creato da ArcView per organizzare e mantenere 
memoria di tutto il lavoro fatto. In questo file vengono scritte dal sistema tutte le 
operazioni eseguite con i documenti di ArcView. I file di progetto hanno estensione 
“apr” e sono consultabili ed editabili (consigliato per gli esperti) con i più comuni 
editor di testo. L’importanza di questo file è indubbia in quanto permette di salvare il 
lavoro in qualsiasi momento, sicuri, di poterlo riprendere nella posizione in cui 
l’abbiamo lasciato. Anzi è consigliabile eseguire questa operazione con intervalli 
frequenti allo scopo di contenere eventuali perdite di dati, di ore lavorate ed evitare 
noiose e ripetitive operazioni. 

 
10.  Salvare il lavoro in un progetto 

Dal menu File -> Save Project As, conferma con il tasto sinistro del mouse, si apre 
una finestra di dialogo. Dove la casella File Name presenta un nome di default 
proj.apr che si sostituirà con Unità1,  infine posizionarsi nella direttory ……… e click 
sul pulsante Ok. 
 

Utilità 
 
Prima del riepilogo una breve descrizione dei principali comandi di ArcView 
 
 

 
 
 
 
 
 
 
 
 
 
 

 
 
 



 

Riepilogo dei principali comandi 
 
Avvio/Start -> Programmi -> Esri -> ArcView Gis 3.2 
 
Nella finestra Welcome to ArcView GIS scegliere as a blank project 
 
Creare una nuova View, click sul pulsante New 
 
Menu View, click sulle Properties 
Name Dati Geografici 
….. 
Creator data del sistema 
Map Units selezionare meters 
Distance Units selezionare meters 
Ok 
 
Menu File, click su Esxtension 
selezionare Cad Reader 
Ok 
 
Menu View, click su Add Theme 
selezionare il tema  
dati\Infrastrutture.shp, OK 
dati\Idrografia.shp, OK 
dati\Comuni_archi.shp, Ok 
dati\Comuni.shp, Ok 
dati\Centro_urbano.shp, Ok 
verificare in sommario il contenuto 
click sul pulsante vicino al nome per attivare o disattivare i singoli temi 
ripetere il punto 6.1 per le regole di visualizzazione 
 
selezionare il file di interscambio comuni.dxf 
pulsante sinistro del mouse sulla cartella  e click 
fra le opzioni scegliere polygon e point, Ok 
click sul pulsante vicino al nome per attivare o disattivare i singoli temi in legenda 
 
Salvare il progetto 
Menu File -> Save Project As  
Unità1 
Ok 
 
 
 
Esercizi 
Le utility di importazione dei dati non proprietari in ArcView sono estremamente utili in quanto 
offrono la possibilità di utilizzare dati gia preparati. Non sempre questi rispondono alle reali 
necessità. La conoscenza delle problematiche legate alla importazione dei dati è indispensabile. 
Un esercizio utile a proposito è quello di recuperare dei dati in formato CAD (dxf o dwg) o altri 
formati compatibili con le estensioni di ArcView ed eseguire delle importazioni per capire i 
contenuti e valutare vantaggi e svantaggi.  
 
Riferimenti 
ESRI Using ArcView GIS 
 



 

 
 

 

 
 
 
 
 

  
 


